0

I am trying to run selenium using chrome-driver in my project. While creating object of chrome-driver facing errors :

Message "unknown error: cannot find Chrome binary\n (Driver info: chromedriver=81.0.4044.20

Please let me know if anyone face/fix this issue.

Error 1 :

{"unknown error: Chrome failed to start: crashed.\n (unknown error: DevToolsActivePort file doesn't exist)

Error 2 :

{"unknown error: Failed to create a Chrome process.\n (Driver info: chromedriver=2.41.578737

1

Chrome is currently on v91 and it needs a driver to match. Install Chrome in its default location and make sure it is updated. Then get the latest Chromedriver. There's a NuGet package for chromedriver if you prefer to manage it that way.

5
  • Thanks for quick response @kirbycope. yes I have installed chrome v 90.0. matched chrome-driver and req. NuGet packages has been installed. No error observed. Still getting error - Failed to crated a Chrome process\n . . . Apr 28 at 14:23
  • 1
    @NarendraC note he said Chrome is on v91, not v90, which you've mentioned...
    – Mark Mayo
    Apr 29 at 1:18
  • Yeah, the joy of auto updates.
    – kirbycope
    Apr 29 at 3:19
  • @MarkMayo Thanks . Yes I have tried with v91 and v90. Today I am planning to downgrade even further, That is the only option I can see as of now. Apr 30 at 5:27
  • Matched chrome & driver version. Installed chrome in its default location @kirbycope as suggested.Still observed errors. Small fine tuning resolve issue. Catch was - I uninstalled my Chrome browser manually and install it again. Voila :) Everything started working as expected. May 4 at 6:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.