0

I am using Jenkin Pipeline to execute by test , every thing work fine bit allure-result and allure report is not getting generated , tried all blogs still not able to get in

Here is console log for pipeline

Commit message: "Added Allura 1"
 > git rev-list --no-walk 3fff9667098e8dbc603e0b665a858e6273d34b73 # timeout=10
[Pipeline] }
[Pipeline] // stage
[Pipeline] stage
[Pipeline] { (Run Test)
[Pipeline] echo
Running....
[Pipeline] sh
+ allure --version
2.9.0
[Pipeline] }
[Pipeline] // stage
[Pipeline] stage
[Pipeline] { (Generate Allure Reports)
[Pipeline] allure
[Pipeline] }
[Pipeline] // stage
[Pipeline] }
[Pipeline] // withEnv
[Pipeline] }
[Pipeline] // node
[Pipeline] End of Pipeline
java.lang.NullPointerException
    at ru.yandex.qatools.allure.jenkins.AllureReportPublisherDescriptor.getCommandlineInstallation(AllureReportPublisherDescriptor.java:112)
    at ru.yandex.qatools.allure.jenkins.AllureReportPublisher.getCommandline(AllureReportPublisher.java:346)
    at ru.yandex.qatools.allure.jenkins.AllureReportPublisher.generateReport(AllureReportPublisher.java:303)
    at ru.yandex.qatools.allure.jenkins.AllureReportPublisher.perform(AllureReportPublisher.java:231)
    at jenkins.tasks.SimpleBuildStep.perform(SimpleBuildStep.java:123)
    at org.jenkinsci.plugins.workflow.steps.CoreStep$Execution.run(CoreStep.java:99)
    at org.jenkinsci.plugins.workflow.steps.CoreStep$Execution.run(CoreStep.java:69)
    at org.jenkinsci.plugins.workflow.steps.SynchronousNonBlockingStepExecution.lambda$start$0(SynchronousNonBlockingStepExecution.java:47)
    at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:515)
    at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
    at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
    at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
    at java.base/java.lang.Thread.run(Thread.java:829)
Finished: FAILURE

As you can see , Allure version is been fetched

And here is jenkin pipline file

pipeline {
    agent any
    environment {
        APPIUM_PORT= 4723
    }
    
    
    stages {
        stage('PULL FROM GIT') {
            steps {
                echo "GIT.."
                git credentialsId: 'gitHubCred', url: 'https://user.git'
            }
        }
        
        stage('Run Test') {
            steps {
                echo "Running...."
                sh "allure --version"
            }
        }
        
             stage('Generate Allure Reports') {
        steps {
          allure commandline: 'allure', includeProperties: false, jdk: '', results: [[path: 'allure-results']]
        }
    }

    }
}

I am using AWS instance , what wrong I am doing here ???

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.