0

I'm getting strange error using Selenium WebDriver with IE (version 11). Here log of Selenium:

D 2021-06-02 16:33:46:334 c:\projects\webdriver\cpp\iedriver\elementfinder.cpp(60) Using FindElement atom to locate element having xpath = //*[@data-at-selector='formsKisConnectSignUpDialog']//*[@id='EMail']
I 2021-06-02 16:33:46:334 c:\projects\webdriver\cpp\iedriver\browser.cpp(142) No child frame focus. Focus is on top-level frame
D 2021-06-02 16:33:46:560 c:\projects\webdriver\cpp\iedriver\variantutilities.cpp(105) Result type is JScriptTypeInfo
D 2021-06-02 16:33:46:571 c:\projects\webdriver\cpp\iedriver\variantutilities.cpp(105) Result type is JScriptTypeInfo
D 2021-06-02 16:33:46:589 c:\projects\webdriver\cpp\iedriver\variantutilities.cpp(105) Result type is JScriptTypeInfo
W 2021-06-02 16:33:46:919 c:\projects\webdriver\cpp\webdriver-server\response.cc(98) Error response has status code 32 and message 'Unable to locate an element with the xpath expression //*[@data-at-selector='formsKisConnectSignUpDialog']//*[@id='EMail'] because of the following error:
[object Error]' message
D 2021-06-02 16:33:46:923 c:\projects\webdriver\cpp\iedriver\iecommandexecutor.cpp(786) Setting serialized response to {
    "value" : 
    {
        "data" : null,
        "error" : "invalid selector",
        "message" : "Unable to locate an element with the xpath expression //*[@data-at-selector='formsKisConnectSignUpDialog']//*[@id='EMail'] because of the following error:\n[object Error]",
        "stacktrace" : ""
    }
}

Obviously the selector is good, nothing wrong with the specified XPath. The error occurs only with IE.

I'm trying to get element with just RemoteWebDriver.FindElement with By.XPath in C#.

4
  • 1
    please add the code that throws this error – PDHide Jun 4 at 8:20
  • @PDHide added info about how I get an element. Code actually won't add additional info. I just use FindElement. – Maxim Jun 4 at 12:50
  • /*[@data-at-selector='formsKisConnectSignUpDialog']//*[@id='EMail'] is this a valid input ,if you try this on developer console? – ChathuD Jun 5 at 12:35
  • @Maxim Check xpath for IE. Seems xpath is not valid for IE. – Mat Jun 9 at 6:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.