0

So I'm currently writing automation tests on a blazer app which uses DevExpress-DevExtreme MultiSelects (testing in a chrome browser). See here for a similar working example (Data Grid not TreeView):

https://js.devexpress.com/Demos/WidgetsGallery/Demo/DropDownBox/MultipleSelection/jQuery/Light/

My code might look like this:

Driver.FindElement(By.XPath("//div[@class='dx-dropdowneditor-icon']")).Click();

The problem I am having is when I try to open the multiselect for the first time after page refresh using selenium it comes up blank with no data and sometimes throws an error in the console. This error or weird behaviour never happens when manually using it. It also does not happen if data comes preselected in the dropdown.

If however I put a breakpoint before selenium tries to open it, and open it myself (populates with data fine), selenium can then open the multiselect as normal.

  1. I have tried using different elements to click to open (divs that act as the buttons, input box itself)
  2. I have tried waiting for 30 seconds plus just to make sure the page has loaded properly

What it should look like: https://i.stack.imgur.com/6O2yS.png

What it looks like when selenium opens it: https://i.stack.imgur.com/fYL2m.png

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.