I have a GIS related desktop application on RHEL which communicates to server for fetching and posting data. I am trying to use Jmeter for recording the human actions, I changed the proxy settings of the Linux machine also so that tool could capture traffic but recorder is not able to record anything. Changed configurations are below:

  1. port Used in Jmeter is 8888, same port is set in network settings of Linux machine.
  2. IP changed to localhost or or the system's ip.

What else needs to be done or other way has to used...Please suggest.

1 Answer 1

  1. It might be the case your application doesn't respect system-wide proxy settings and it either has its own separate proxy configuration like i.e. Firefox browser does or respects http_proxy environment variable instead
  2. In case of HTTPS traffic you need to import JMeter's MITM certificate into your RHEL trust store
  3. As it evidenced by its name JMeter's HTTP(S) Test Script Recorder can only record HTTP or HTTPS traffic, if your application uses different protocol(s) you will need to use a sniffer tool like tcpdump and then look for suitable JMeter Samplers or JMeter Plugins which support this(ese) protocol(s)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.