0

I am trying to resolve a compatibility issue between Chromedriver and Chrome browser, but none of the solutions I have tried have worked so far(mentioned below). I have latest chrome driver and chrome browser version installed but seems like it’s pointing to a different chromedriver which I’m not sure where to find. Location of my chromedriver is /opt/homebrew/bin/chromedriver. Please kindly help me understand what is wrong here? I have added all the details below. Thanks for your help!!Specifications:

ChromeDriver version 113.0.5672.63

Chrome browser version 113.0.5672.126

ERROR webdriver: Request failed with status 500 due to session not created: session not created: This version of ChromeDriver only supports Chrome version 108 Current browser version is 113.0.5672.126 with binary path /Applications/Google Chrome.app/Contents/MacOS/Google Chrome

Solution tried

  • Uninstalling and reinstalling chrome driver by using brew install --cask chromedriver
  • Uninstalling and reinstalling chrome browser
  • Removing chromedriver from this location /opt/homebrew/bin/chromedriver and manually adding it to folder usr/local/bin
  • xattr -d com.apple.quarantine /opt/homebrew/Caskroom/chromedriver to remove restriction
1

1 Answer 1

0

Above issue is resolved. I was using npm install to update chromedriver version but it didn't work. Found the solution https://stackoverflow.com/questions/69439276/npm-install-chromedriver-is-not-working-properly. Thanks

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.