0

I have a site that sits within corporate firewall. When I start JMeter with corporate proxy address defined (ie parameters in command line) and start recording a scenario, page gets blocked by corporate proxy - address not recognised. When I start JMeter with no proxy defined though and record the website activity, I see the basic html page (just a border) but no content is loaded - basically because the main content is from external resources and blocked (because no corporate proxy details were supplied I believe- don't have error message immediately to hand). Is there any way to specify domains that should be excluded from using corporate proxy when recording? Why does this issue not occur other times? I'm assuming that plenty of our internal sites use external resources, eg .js packages? Am using FoxyProxy Chrome addin for ref. Am trying the Blazemeter AutoCorrelation tool for recording. Thanks

1 Answer 1

1
  1. Make sure to import JMeter's certificate into the browser. The file is called ApacheJMeterTemporaryRootCA.crt and it's generated in "bin" folder of your JMeter installation when you start HTTP(S) Test Script Recorder. See HTTPS recording and certificates chapter of JMeter Documentation for more details.
  2. Clear your browsing history
  3. There is no need to use any add-in, just configure Chrome to use JMeter as the proxy. Alternatively go for the browser which has independent proxy configuration like Firefox. Also set JMeter to use your corporate proxy. There is a way to specify host(s) for which proxy will not be used (the connection will be direct). However it means that these requests will not be intercepted
  4. I don't think you should record and especially replay external resources for the internal application, you should exclude them from recording and replaying scope
1
  • Thanks you Dimitri - problem now resolved! Points 1 and 2 were done (imported cert and always use Incognito). Point 4 - in the process of reviewing. Point 3 was the issue - I had started JMeter from the command line with parameters as per section 1.4.3 in the manual but the parameter -N was incorrect. Once I added the domain for local addresses eg "-N *.my.local.domain.com" as an exclusion for the proxy, all was good. Thanks again
    – DanUK
    Jun 20, 2023 at 14:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.