1

After using selenium 4.11.0 version and launch error for 116 browser launch error was resolved.

Has anyone observed Maximum CPU utilization issue after changing to selenium 4.11.0?

I was using selenium 4.8.3 before and I was not facing any issues. After changing to selenium 4.11.0 the CPU issue started.

Before my selenium version was 4.8.3 and chrome browser version was 115. My scripts worked without problems.

Now my selenium version is 4.11.0 and chrome browser version is 116. I did not change anything else. Is this a problem with the selenium version or the browser?

2
  • I have the same issue. It was related to version 116 of the chromediver. Edge and Gecko are still working the same. I upgraded Selenium from 4.10 to 4.11 and nothing changed. I also switched on the selenium-manager feature so I immediately get the new driver when it is fixed. The problem persists. Commented Aug 23, 2023 at 16:47
  • What numbers you had for max CPU utilization before and after?
    – Mate Mrše
    Commented Aug 24, 2023 at 7:05

1 Answer 1

0

For me, the solution turned out to be commenting out the "-no-sandbox" argument. This was added years ago to solve a problem running the tests on an Azure DevOps VM. Today we use our own build servers so I don't know if the argument is needed for the original cause, but many messages discourage its use.

2
  • Thank you I refer to the link "stackoverflow.com/questions/21320837/…" one guy suggested to use of driver.close(); and driver.quit() to resolve the issue. tried with this suggestion. In my current code only driver.quit() was used. with the update its working fine. The CPU problem was caused because the driver.quit() was closing the browser ideally it should as a result many browser was still running in background process(verified in task manger). but adding driver.close() before driver.quit() the issue was resloved
    – Likitha Hs
    Commented Aug 25, 2023 at 17:57
  • Thank you. I had the same situation. I added the Close as well. Commented Aug 28, 2023 at 14:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.