I am a pretty fast (>100WPM) typer and I am constantly hitting issues with QTP recognizing my input/keeping up.

Two examples that come immediately to mind:

  • Shift+Space does not actually put in a space.
  • Shift+BkSp undoes my backspace.

Is there ANY way to get QTP 11 to act like a regular program? Shift+Space should still insert a space (just tried this while typing the question) and Shift+BkSp still deletes characters, like it should.

I'm constantly missing spaces during my test scripts (i.e. HELLOWORLD instead of HELLO WORLD) and I'm constantly having to redo my backspaces after a shift+BkSp entry.


1 Answer 1


I found a partial solution to your problem.

You can change the Key Bindings with Tools>Options>Key Bindings. Unfortunately, you cannot use the Backspace as new shortcut key, because the interface thinks you want to delete the previous character (try it if you want, I wasn't able to do this in QTP 10). So we have to work around this:

  1. Close QTP
  2. Go to the bin folder of the QTP installation. In my case it was here: C:\Program Files (x86)\HP\QuickTest Professional\bin
  3. Open the QTEditor.ini file Change line Delete before cursor=2097701 to Delete before cursor=2097701,35652133
  4. Change line Undo=35652095,35652133 to Undo=35652095
  5. Save the file
  6. Open QTP, you can now use SHIFT + Backspace to delete a character.

Unfortunately, you cannot enter a shortcut key for forward space.

  • Thanks -- I'll give this a shot. I'm aware of the key bindings option inside QTP but I can never get the options to stick through a restart of the application.
    – Frank
    Feb 5, 2013 at 15:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.