I've got Jenkins set up to build my application test target and execute tests in the iOS simulator like this answer says. When I execute the build in Jenkins, the iOS simulator launches and runs all of my tests, but I only get output in the test log for the first test.

If I run xcodebuild from the command line it also runs all of my tests, but I do get output for all of the tests.

Does anybody have any idea what could be going wrong in Jenkins or suggestions for further troubleshooting? Thanks!

  • I haven't run into this, but is it possible that each test result returned counts as a 'complete' message from stdout? So Jenkins would stop once the first result is returned because it thinks it has received the 'all clear' (shell returns a "0" all clear)? – maznika Mar 29 '13 at 19:42
  • 1
    The program that produces the output was still executing and does not return a shell exit code until it completes all tests. I ended up writing another script that wraps the program and reproduces its output. Hacky fix, but it eventually got me where I needed to be. – Greg Mar 29 '13 at 19:48
  • Wow. Very strange, but your fix was all I could think of as well for a work around. – maznika Mar 29 '13 at 20:37
  • @Greg I know this is a bit old, but if it's not too much trouble, would you be able to turn this into legit answer, and then accept it? I feel like this information could be useful, especially if it came from a search engine, to someone who has the same problem. If they see it has no answer, and don't bother to read the comments, they may just move on when they could have had their problem solved. Thanks! – corsiKa Mar 6 '14 at 21:36