When I set the proxy setting in a browser as then I am able to run the JMeter recorder for the project I am running using JBoss server from my system only that is ok and doing enough.

Now, when I try to use google or some other site it simply shows error page even for other web app. I am attaching proxy set image, please tell me how to use JMeter using proxy setting form application whose server is on some other address or location (in short, not from my system/JBoss)enter image description here

  • In your browser with the proxy set up the way you show, are you able to navigate to google.com? Also, you may want to tell Firefox to use the system proxy settings, and change those, that way many other browsers and applications will automatically use those settings.
    – Sam Woods
    Oct 22, 2014 at 15:39

3 Answers 3


I believe that you need to remove localhost and from "No Proxy For" input in your Firefox configuration.

As per HTTP Proxy Server guide the idea of recording is pointing your browser to hit application under test through JMeter Proxy.

By default JMeter proxy is running on localhost on port 8080. Your configuration assumes not using proxy for localhost/ and address.

If your organization uses proxy for internet access - you'll need to tell JMeter to use this proxy as well in order to be able to access the Internet.

It can be done via command line arguments as follows:

   -H, --proxyHost <argument>
            Set a proxy server for JMeter to use
    -P, --proxyPort <argument>
            Set proxy server port for JMeter to use
    -N, --nonProxyHosts <argument>
            Set nonproxy host list (e.g. *.apache.org|localhost)
    -u, --username <argument>
            Set username for proxy server that JMeter is to use
    -a, --password <argument>
            Set password for proxy server that JMeter is to use

Alternatively, record the test without using Proxy. SmartMeter Recorder uses Chrome plugin for test recording thus avoiding any difficulties with setting up the proxy server.


As Dmitri T said - the "No Proxy for.." should be removed... but also ensure that when you are trying to access the internet that you leave the JMeter proxy recorder running while the localhost:port proxy settings are active in your browser.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.