Skip to main content
Share Your Experience: Take the 2024 Developer Survey

Questions tagged [android-automation]

The tag has no usage guidance.

14 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
4 votes
1 answer

uiautomatorviewer not running on Mac Big Sur

I'm trying to run uiautomatorviewer on Big Sur and I'm getting this error java.lang.NullPointerException at org.eclipse.swt.widgets.Control.internal_new_GC(Unknown Source) at org.eclipse.swt....
Noldy's user avatar
  • 41
2 votes
2 answers

Appium - 'POST /element' cannot be proxied to UiAutomator2 server because the instrumentation process is not running

I am trying to run an automated test in appium, what happens is that the app does get launched however fails to perform any action. Please see error below: An unknown server-side error occurred while ...
Aubrey Fredericks's user avatar
2 votes
0 answers

I have been struggling for more that a day to fix the Duplicate class given when running my android project for automation

Error: Duplicate class org.openqa.selenium.SearchContext found in modules jetified-java-client-7.3.0.jar (java-client-7.3.0.jar) and jetified-selenium-server-standalone-3.141.59.jar (selenium-server-...
Rahul Kumar's user avatar
1 vote
2 answers

Appium android clear app data

My scenario is, I'm switching from one app to another in an Android phone. While switching from one app to the other, I want to clear all data or do a hard reset of the app I'm switching from. Also ...
Benjamin's user avatar
1 vote
0 answers

What is fast reset in appium, which I am getting in appium server logs and how to avoid it

What is fast reset in appium, which I am getting in appium server logs and how to avoid it...
Ragsurf's user avatar
  • 11
1 vote
0 answers

There is a way to identify font type in an Android app? (Python, Appium)

Here is the deal: i'm testing an android app and the client wants us to test font types, sizes and colors. Using Appium's explorer i'm able to see the objects properties (such us: text, enabled, etc) ...
Pablo Fernandez's user avatar
1 vote
0 answers

Locator strategy for list view elements in Android app

I am automating a calendar feature in an Android app using Appium. The developers have set content-desc for us to be used as accessibility ids. For simple elements like buttons it works like a charm. ...
Roohi Bhatnagar's user avatar
1 vote
0 answers

How to test that a link from the app opens up in chrome browser using espresso

I have an app in which users can search for a text and it will populate the related repositories from Github based on that text/search term.I want to write an espresso test to verify that when user ...
philomath's user avatar
0 votes
1 answer

Appium: Parallel execution halts if test is complete on one of the device

I am trying to run 2 different tests on 2 different emulators parallelly. But my execution halts on 1 device as soon as the test on other device is complete. I am using the below driver setup code ...
Sanjay Bhatia's user avatar
0 votes
0 answers

tool recommendation to get line coverage against Manual and Automated test cases (offline instrumentation)

Our team uses the traditional method of building new test cases based on the feature requirements and testing them (manually or through automation) and getting them reviewed by the dev and product ...
AndroidQAE's user avatar
0 votes
0 answers

Appium Desktop cannot start an App installed via Microsoft InTune

I'm using Appium Desktop 1.12.1. I want to start a new session and use Inspector. I have a business app that is usually installed via MS InTune. Essentially InTune means I have two categories of app ...
DanUK's user avatar
  • 123
0 votes
1 answer

App is launched but not able to perform further actions (App automation using appium)

I am new in mobile app automation I have successfully launched Google Playstore application in my android device. but,i can not click on next tab "GAMES". My Code package
Kaushal Patel's user avatar
0 votes
1 answer

When I run my Appium script I am getting error "TypeError [ERR_INVALID_ARG_TYPE]" which I am not able to understand

I wrote a script to automate my app using appium with java-script(nodejs), but when I run it I am getting error. This is the code which I have written. var webdriverio = require('webdriverio'); var ...
manoj's user avatar
  • 117
0 votes
2 answers

Not able to enter case-sensitive credential in android app

I am writing a test case for an android app where the app requires case-sensitive credentials. I writing test cases using appium and TestNG. Steps I am following are - Launching app Entering ...
Ravi Ojha's user avatar
  • 395