I'm currently recording some python test scripts for a Mac OS X application using Squish for Qt, version 4.0.2.

The menu bar of the AUT works fine if interacted with manually, but for some reason Squish refuses to record interactions with it, as if it wasn't part of the AUT at all. As a result, I can't find out its symbolic or real name very easily.

I've tried using keyboard shortcuts to menu items, but they don't work either - or at least, they do nothing when a test is run, even if they look like they should work in the script. Since keyboard shortcuts that don't refer to menu items run just fine, I can't help but think it's related.

I've sucessfully recorded tests that involve menus for the Windows version of the AUT. Since I very much doubt that Froglogic would make their testing tool completely unable to interact with menus on OS X, I think the problem must be with either the Mac version of the AUT or my test scripts.

Has anyone experienced something similar? How did you overcome the problem?

1 Answer 1


squish 4.2 using Qt will record my menu bar interactions, so you may have already done this by now but you can try the latest squish. A problem that I have is bringing the focus back to the AUT once I run the test so that I can test menu bar functionality. Squish hooks into Qt just fine but the problem is the application does not actually have focus when you run the test so the menu bar does not show up even after registering a mouse event somewhere on the application during testing to bring focus. During the test it seems to ignore the recorded mouse event or that maybe how it was intended. An easy work around is snoozing for a few seconds and manually bringing focus to the AUT. Something to consider once you get your issue resolved.

  • Oh-ho! That solved it. Thanks for that. Give yourself a metaphorical pat on the back for helping out with such an old issue.
    – user867
    Commented May 29, 2012 at 4:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.