4

I have a couple of tests, which I run them on windows and I have a successful run. But when I move to UBUNTU server with Xvfb, I faced problem with tests, some of them failed!!

both cases I used:

  • Maven 3.1
  • Selenide v3.5
  • Selenium v2.53
  • Firefox v45.0.1

So from where these problems? is it related to Firefox version? or I have to modify in the code somewhere?

some of them can't run:

org.openqa.selenium.firefox.NotConnectedException: Unable to connect to host 127.0.0.1 on port 7055 after 45000 ms. Firefox console output:

and others can't find elements while executing.

3

If you are using Selenium v-2.53 downgrade your Mozilla Firefox version. Selenium v-2.53 has lots of issues with Mozilla Firefox version above 45. So you may use FF v-31.0. Even I have got same issue with this version & It was resolved with Selenium v-2.52 & FF V-31.0

1

That's a connection issue between Selenium and Firefox. There is an open bug on it here that has some information for potential a work-around.

The issue, from what I have been able to tell is Firefox 45+ is having issues with Multithreading on a single node from Selenium. Potential fix, untested by me and from the bug report linked above, would be to downgrade Firefox.

  • is it solved at Selenium v2.53 ? – Hana90 Apr 25 '16 at 12:14
  • From the link, I would say no. It looks like issues with Selenium and FF45 with multi-threading onto a single node. – Paul Muir Apr 25 '16 at 12:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.