3

Please help me for my setting in appium, I cant launch and display appium inspector on ios, but my setting for android already working and fine

  • use macOS- Sierra
  • appium 1.5.3
  • iphone iOS 10.2

    Launching Appium with command: '/Applications/Appium.app/Contents/Resources/node/bin/node' appium/build/lib/main.js --address "127.0.0.1" --port "4725" --pre-launch --debug-log-spacing --platform-version "9.3.2" --platform-name "iOS" --app "com.dai.uangteman" --udid "c3939d6e3cc39936161a6f554e0ac472cdba0142" --full-reset --device-name "iPhone 5" --isolate-sim-device

    [Appium] Welcome to Appium v1.5.3

    [Appium] Non-default server args:

    [Appium] address: '127.0.0.1'

    [Appium] port: 4725 [Appium] launch: true [Appium]
    isolateSimDevice: true [Appium] debugLogSpacing: true [Appium]
    platformName: 'iOS' [Appium] platformVersion: '9.3.2' [Appium]
    deviceName: 'iPhone 5' [Appium] app: 'com.dai.uangteman' [Appium]
    udid: 'c3939d6e3cc39936161a6f554e0ac472cdba0142' [Appium] fullReset: true [Appium] Deprecated server args: [Appium] --platform-name => --default-capabilities '{"platformName":"iOS"}'

    [Appium] --platform-version => --default-capabilities '{"platformVersion":"9.3.2"}' [Appium] --device-name => --default-capabilities '{"deviceName":"iPhone 5"}' [Appium] --app => --default-capabilities '{"app":"com.dai.uangteman"}' [Appium] -U,--udid => --default-capabilities '{"udid":"c3939d6e3cc39936161a6f554e0ac472cdba0142"}' [Appium]
    --full-reset => --default-capabilities '{"fullReset":true}' [Appium] Default capabilities, which will be added to each request unless overridden by desired capabilities:

    [Appium] platformName: 'iOS'

    [Appium] platformVersion: '9.3.2' [Appium] deviceName: 'iPhone 5' [Appium] app: 'com.dai.uangteman' [Appium] udid: 'c3939d6e3cc39936161a6f554e0ac472cdba0142' [Appium] fullReset: true

    [Appium] Appium REST http interface listener started on 127.0.0.1:4725

    [HTTP] --> GET /wd/hub/status {}

    [MJSONWP] Calling AppiumDriver.getStatus() with args: []

    [MJSONWP] Responding to client with driver.getStatus() result: {"build":{"version":"1.5.3"...

    [HTTP] <-- GET /wd/hub/status 200 21 ms - 83

below images is my setting appium

enter image description here

enter image description here

0

Try opening terminal and type:

sudo chmod -R 777 /var/db/lockdown/

(If this would work, you would need to do this after every boot of MacOS)

Also try to:

  • Change xcode to <= 8.1
  • Try iOS device <= 9.X

Try all 3 steps together.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.