1

Selenium 3 came out in 2016.

Which ruby test frameworks have adopted it?

I want to use contains which is available in Selenium 3 for selecting elements.

1

Here are the listed dependencies (as of 6/14/2017)

capybara

selenium-webdriver < 4.0, >= 2.0

Except version 3.4.1 due to this issue.

s.add_development_dependency("selenium-webdriver", [">= 2.0", "< 4.0", "!=3.4.1"])

watir

selenium-webdriver >= 2.46.2

0

As of 06/14/2017

capybara is still on Selenium 2

watir release 6.0 (Nov 9th 2016) has support for Selenium 3

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.