2

I am running the application under test on Chrome-Version 49.0.2623.112 m (64-bit) manually. When I click on a particular button "Ophalen", a web service request is made and the responses are parsed and displayed on the UI.

When I attempt to do the same thing using chromedriver and selenium 2.53, I can see that the button is clicked but the responses are not displayed on the UI. Consequently my test is failing when I use chrome browser to run my test.

The same test is running perfectly fine on firefox browser.

Can I safely conclude that my application is not compatible with chrome, but I cannot justify this because, I am able to get the web service response when I perform the action manually.

Please post your opinions.

Thanks!

1

I can see that the button is clicked but the responses are not displayed on the UI. Consequently my test is failing when I use chrome browser to run my test.

Selenium executes tests much faster in Chrome than Firefox; noticeably faster. So you might have a test that passes in Firefox but fails in Chrome because an element (often NoSuchElementError or StaleElementReferenceError) isn't ready.

It's nice that Firefox is slow enough to visually see what is happening but you need to be able to debug your tests. In Chrome this is a must. Try working out your logic, print lines to the console if necessary and hopefully in this case it's just a timing issue where you just need to wait for certain elements to appear.

For more information on Implicit and Explicit waits see Elemental Selenium Tip 47.

  • I have tried everything except Robot class to cross-check if the particular button is clicked and with the print statement also, I re-confirmed that the button was clicked. However, the response was not displayed. Also, as you suggested, I have tried both Implicit and Explicit waits for upto atleast 5 mins but nothing happened. – user6376 May 4 '16 at 17:09
0

I had exactly the same issue and I have solved it calling my button with the new xpath. In other words, my button had an xpath when it was pristine, for instance, the one that firepath was giving me, so I could click on it succesfully but it did nothing. When it was "doing things" its xpath was different, and I could find it only hovering the mouse on it in the DOM where it lives. there was something like b=>b under the element code. Hovering my mouse there revealed a second xpath. So I readjusted my code as follows: "wait until element is enabled" xpath1 "click on element" xpath1 sleep 1s "click on element" xpath2.

I don't know whether I really needed all of that, to be honest I am still new to RobotFramework but...it worked.

I hope this helps.

  • I do not understand what you mean by b=>b. Could you explain further please? For the element that I am looking for, the DOM is something like this: <button data-ctl="" data-click="[["refresh", ["otherSection","GetLoan", "", "&=", "", "SetSearchPerformed,Performed=true",":event","","pyWorkPage"]]]" name="SelectLoan_pyWorkPage_5" class="pzhc pzbutton" type="button">Ophalen</button> – user6376 Jan 26 '18 at 12:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.