3

Currently, I have an integration between GIT, Jenkins and SonarQube as described in this pseudo workflow:

commit----> AWS CodeCommit (GIT) <-> Jenkins <-> SonarQube Scanner for Maven <-> SonarQube

Software involved:

  • Jenkins v2.110
  • SonarQube Scanner for Jenkins v2.6.1
  • SonarQube v6.7.0.33306

The builds in Jenkins are triggered manually (clicking on the run button). Once triggered, SonarQube validates the code and publishes the report. The problem is that, when SonarQube generates an issue, the issue doesn't get auto-assigned to any user.

Things to have in mind:

  • This setup worked for about 2 to 3 months. I don't know the exact point when it stopped working.
  • All the users in SonarQube have their respective SCM Account configured correctly in their profiles.
  • SonarQube effectively generates the issue report and sends the issues (e-mail) to administrators registered in the project involved.

The reports generated are correct, so I'm assuming that the interaction between SonarQube and Jenkins is OK. Is that assumption correct?

Is there a log I can check to see more clearly what is going on with the issue assignment?
Any idea of how can I fix this?

Best Regards, Pedro Riffo

  • I am also facing same issue, can i have any solutions here please – user36774 Jan 25 '19 at 11:49
  • Have you tried running the analyisis with sonar.verbose=True option to get more info in log files? – Prome Oct 29 '19 at 8:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.